aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authortdro <tdro@noreply.example.com>2024-02-24 18:33:47 -0500
committertdro <tdro@noreply.example.com>2024-02-24 18:33:47 -0500
commite8c7ffdfe80b83f54e1bee2120ed7ac8e9d308f4 (patch)
tree02cc1058c7fa0b211372fafe2d26ced1134979f4 /shell.nix
parentb334453f50db6a571714d59e4d8dbcc84744f675 (diff)
downloadcanory-e8c7ffdfe80b83f54e1bee2120ed7ac8e9d308f4.tar.gz
canory-e8c7ffdfe80b83f54e1bee2120ed7ac8e9d308f4.tar.bz2
canory-e8c7ffdfe80b83f54e1bee2120ed7ac8e9d308f4.zip
shell: Park at hugo version 0.122.0
Increase shell build ergonomics
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index f7c9419..d56214d 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,23 +2,25 @@ let
name = "nix-shell.canory";
+ system = builtins.currentSystem;
+
pkgs = import (builtins.fetchTarball {
url = "https://releases.nixos.org/nixos/unstable/nixos-23.11pre516114.d680ded26da5/nixexprs.tar.xz";
sha256 = "13cnlhpp3v7jay4jxyyy2d4kxw4ngpz3m00rhj3vlhvf7jl7hr48";
- }) { system = "x86_64-linux"; };
+ }) { inherit system; };
hugo = pkgs.callPackage ({ lib, buildGoModule, fetchgit }:
buildGoModule rec {
pname = "hugo";
- version = "0.121.1";
+ version = "0.122.0";
src = fetchgit {
rev = "v${version}";
url = "https://github.com/gohugoio/hugo.git";
- sha256 = "sha256-XNOp0k2t5Tv4HKKz3ZqL/sAdiYedOACaZ/1T7t7/Q1A=";
+ sha256 = "sha256-pnsQo+nSuIlQ6KKTP1z/BZ74zEu9HjYP66hGStPc0pc=";
};
doCheck = false;
proxyVendor = true;
- vendorSha256 = "sha256-J/me67pC+YWjGIQP6q1c+vsSXFxXoLZV7AyDv3+606k=";
+ vendorSha256 = "sha256-aYy0TOfNIqx44UBXJhewvxi+oSAWjmi/32WvI3HJ3MM=";
tags = [ "extended" ];
subPackages = [ "." ];
meta = {