aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index b409531..4850800 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,8 +3,8 @@ let
name = "nix-shell.canory";
pkgs = import (builtins.fetchTarball {
- url = "https://releases.nixos.org/nixos/23.05/nixos-23.05.563.70f7275b32f/nixexprs.tar.xz";
- sha256 = "09r197c4b1asjmqyna3k0bmjv5djijcaz5k6fbakrq32kd67sl36";
+ url = "https://releases.nixos.org/nixos/unstable/nixos-23.11pre516114.d680ded26da5/nixexprs.tar.xz";
+ sha256 = "13cnlhpp3v7jay4jxyyy2d4kxw4ngpz3m00rhj3vlhvf7jl7hr48";
}) { system = "x86_64-linux"; };
hugo = pkgs.callPackage ({ lib, buildGoModule, fetchgit }:
@@ -34,6 +34,8 @@ let
/usr/bin/env --ignore-environment /bin/sh -c ${
pkgs.writeScript name ''
export PS1='\h (${name}) \W \$ '
+ export HOME=$PWD
+ export HISTFILE=
export DENO_DIR=vendor
export DENO_NO_UPDATE_CHECK=1
export PATH=${pkgs.lib.strings.makeBinPath [