aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authortdro <tdro@noreply.example.com>2022-12-03 20:09:08 -0500
committertdro <tdro@noreply.example.com>2022-12-03 20:09:08 -0500
commit3be44b5e0e224ad2d19f5af479de58680ee905fa (patch)
tree7647b99bf960318ff13e42383a5962052f9187c6 /shell.nix
parentd27acd8bb3bdbfa1c8a70b76592f9c39eed18810 (diff)
downloadcanory-3be44b5e0e224ad2d19f5af479de58680ee905fa.tar.gz
canory-3be44b5e0e224ad2d19f5af479de58680ee905fa.tar.bz2
canory-3be44b5e0e224ad2d19f5af479de58680ee905fa.zip
assets: Add schemas
House keeping guardrails
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 76d3906..151c411 100644
--- a/shell.nix
+++ b/shell.nix
@@ -17,6 +17,11 @@ let
sha256 = "1ciwifsx2hrp0ymm077zfb5q8ravrk545bda1q249y2spw9np4ms";
}) { };
+ check-jsonschema = pkgs.callPackage (pkgs.fetchurl {
+ url = "https://raw.githubusercontent.com/NixOS/nixpkgs/82e9e32436d5886102f1e5f7c17aed8475504991/pkgs/development/tools/check-jsonschema/default.nix";
+ sha256 = "sha256-PImZIMGa6+DE2f4tXiPS8ck7enThJvi9uiyxHvXm9WQ";
+ }) { };
+
hugo = pkgs.callPackage ({ lib, buildGo118Module, fetchgit, installShellFiles }:
buildGo118Module rec {
@@ -55,6 +60,7 @@ in mkShellPure {
inherit hugo;
packages = [
+ check-jsonschema
hugo
validatornu
pkgs.busybox
@@ -62,6 +68,8 @@ in mkShellPure {
pkgs.entr
pkgs.git
pkgs.gnumake
+ pkgs.jing
+ pkgs.libxml2
pkgs.libxslt
pkgs.php
pkgs.subversion